CVE-2021-38593

NameCVE-2021-38593
DescriptionQt 5.x before 5.15.6 and 6.x through 6.1.2 has an out-of-bounds write in QOutlineMapper::convertPath (called from QRasterPaintEngine::fill and QPaintEngineEx::stroke).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qtbase-opensource-src (PTS)stretch5.7.1+dfsg-3+deb9u2fixed
stretch (security)5.7.1+dfsg-3+deb9u3fixed
buster5.11.3+dfsg1-1+deb10u4fixed
buster (security)5.11.3+dfsg1-1+deb10u3fixed
bullseye5.15.2+dfsg-9fixed
bookworm, sid5.15.4+dfsg-3fixed
qtbase-opensource-src-gles (PTS)bullseye5.15.2+dfsg-4fixed
bookworm, sid5.15.4+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qtbase-opensource-srcsource(unstable)(not affected)
qtbase-opensource-src-glessource(unstable)(not affected)

Notes

- qtbase-opensource-src <not-affected> (Vulnerable code introduced later)
- qtbase-opensource-src-gles <not-affected> (Vulnerable code introduced later)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=35566
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/qt/OSV-2021-903.yaml
https://github.com/qt/qtbase/commit/1ca02cf2879a5e1511a2f2109f0925cf4c892862 (6.1)
https://github.com/qt/qtbase/commit/202143ba41f6ac574f1858214ed8bf4a38b73ccd (6.2)
https://github.com/qt/qtbase/commit/6b400e3147dcfd8cc3a393ace1bd118c93762e0c (dev)
Introduced by https://github.com/qt/qtbase/commit/6869d2463a2e0d71bd04dbc82f5d6ef4933dc510 (6.0)

Search for package or bug name: Reporting problems