CVE-2021-38714

NameCVE-2021-38714
DescriptionIn Plib through 1.85, there is an integer overflow vulnerability that could result in arbitrary code execution. The vulnerability is found in ssgLoadTGA() function in src/ssg/ssgLoadTGA.cxx file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2775-1
Debian Bugs992973

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
plib (PTS)buster1.8.5-8+deb10u1fixed
bullseye1.8.5-8+deb11u1fixed
bookworm, sid1.8.5-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
plibsourcestretch1.8.5-7+deb9u1DLA-2775-1
plibsourcebuster1.8.5-8+deb10u1
plibsourcebullseye1.8.5-8+deb11u1
plibsource(unstable)1.8.5-10992973

Notes

https://sourceforge.net/p/plib/bugs/55/

Search for package or bug name: Reporting problems