CVE-2021-3907

NameCVE-2021-3907
DescriptionOctoRPKI does not escape a URI with a filename containing "..", this allows a repository to create a file, (ex. rsync://example.org/repo/../../etc/cron.daily/evil.roa), which would then be written to disk outside the base cache folder. This could allow for remote code execution on the host machine OctoRPKI is running on.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5033-1, DSA-5041-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cfrpki (PTS)bullseye (security), bullseye1.4.2-1~deb11u1fixed
bookworm, sid1.4.4-1fixed
fort-validator (PTS)bullseye (security), bullseye1.5.3-1~deb11u1fixed
bookworm, sid1.5.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cfrpkisourcebullseye1.4.2-1~deb11u1DSA-5041-1
cfrpkisource(unstable)1.4.0-1
fort-validatorsourcebullseye1.5.3-1~deb11u1DSA-5033-1
fort-validatorsource(unstable)1.5.3-1

Notes

https://github.com/cloudflare/cfrpki/security/advisories/GHSA-cqh2-vc2f-q4fh

Search for package or bug name: Reporting problems