CVE-2021-39358

NameCVE-2021-39358
DescriptionIn GNOME libgfbgraph through 0.2.4, gfbgraph-photo.c does not enable TLS certificate verification on the SoupSessionSync objects it creates, leaving users vulnerable to network MITM attacks. NOTE: this is similar to CVE-2016-20011.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs993537

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gfbgraph (PTS)stretch0.2.3-1vulnerable
buster0.2.3-3vulnerable
bookworm, bullseye, sid0.2.4-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gfbgraphsource(unstable)(unfixed)993537

Notes

[bullseye] - gfbgraph <no-dsa> (Minor issue)
[buster] - gfbgraph <no-dsa> (Minor issue)
[stretch] - gfbgraph <postponed> (Minor issue, revisit when/if fixed upstream)
https://blogs.gnome.org/mcatanzaro/2021/05/25/reminder-soupsessionsync-and-soupsessionasync-default-to-no-tls-certificate-verification/
https://gitlab.gnome.org/GNOME/libgfbgraph/-/issues/17

Search for package or bug name: Reporting problems