CVE-2021-39359

NameCVE-2021-39359
DescriptionIn GNOME libgda through 6.0.0, gda-web-provider.c does not enable TLS certificate verification on the SoupSessionSync objects it creates, leaving users vulnerable to network MITM attacks. NOTE: this is similar to CVE-2016-20011.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs993592

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgda5 (PTS)buster5.2.8-1vulnerable
bullseye5.2.9-2vulnerable
trixie, bookworm5.2.10-3vulnerable
sid5.2.10-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgda5source(unstable)(unfixed)993592

Notes

[bookworm] - libgda5 <no-dsa> (Minor issue)
[bullseye] - libgda5 <no-dsa> (Minor issue)
[buster] - libgda5 <no-dsa> (Minor issue)
[stretch] - libgda5 <postponed> (Minor issue, revisit when/if fixed upstream)
https://blogs.gnome.org/mcatanzaro/2021/05/25/reminder-soupsessionsync-and-soupsessionasync-default-to-no-tls-certificate-verification/
https://gitlab.gnome.org/GNOME/libgda/-/issues/249
Fixed by: https://gitlab.gnome.org/GNOME/libgda/-/commit/bebdffb4de586fb43fd07ac549121f4b22f6812d (master)

Search for package or bug name: Reporting problems