DescriptionIn GNOME libgda through 6.0.0, gda-web-provider.c does not enable TLS certificate verification on the SoupSessionSync objects it creates, leaving users vulnerable to network MITM attacks. NOTE: this is similar to CVE-2016-20011.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs993592

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgda5 (PTS)bullseye5.2.9-2vulnerable
sid, trixie5.2.10-4.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bookworm] - libgda5 <no-dsa> (Minor issue)
[bullseye] - libgda5 <no-dsa> (Minor issue)
[buster] - libgda5 <no-dsa> (Minor issue)
[stretch] - libgda5 <postponed> (Minor issue, revisit when/if fixed upstream)
Fixed by: (master)

Search for package or bug name: Reporting problems