CVE-2021-3939

NameCVE-2021-3939
DescriptionUbuntu-specific modifications to accountsservice (in patch file debian/patches/0010-set-language.patch) caused the fallback_locale variable, pointing to static storage, to be freed, in the user_change_language_authorized_cb function. This is reachable via the SetLanguage dbus function. This is fixed in versions 0.6.55-0ubuntu12~20.04.5, 0.6.55-0ubuntu13.3, 0.6.55-0ubuntu14.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
accountsservice (PTS)stretch0.6.43-1fixed
buster0.6.45-2fixed
bookworm, bullseye, sid0.6.55-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
accountsservicesource(unstable)(not affected)

Notes

- accountsservice <not-affected> (Ubuntu specific patch)
https://ubuntu.com/security/CVE-2021-3939

Search for package or bug name: Reporting problems