CVE-2021-39536

NameCVE-2021-39536
DescriptionAn issue was discovered in libxsmm through v1.16.1-93. The JIT code has a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs996098

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxsmm (PTS)sid1.9-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxsmmsource(unstable)(unfixed)996098

Notes

https://github.com/hfp/libxsmm/issues/402
https://github.com/hfp/libxsmm/commit/d6984918886d4bd6be241ff3e6af799f4aba3375
https://github.com/hfp/libxsmm/commit/c24027d07eef23411a56958e52afad5ee6db6393

Search for package or bug name: Reporting problems