CVE-2021-40346

NameCVE-2021-40346
DescriptionAn integer overflow exists in HAProxy 2.0 through 2.5 in htx_add_header that can be exploited to perform an HTTP request smuggling attack, allowing an attacker to bypass all configured http-request HAProxy ACLs and possibly other ACLs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4968-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
haproxy (PTS)stretch1.7.5-2fixed
buster1.8.19-1+deb10u3fixed
buster (security)1.8.19-1+deb10u2fixed
bullseye2.2.9-2vulnerable
bullseye (security)2.2.9-2+deb11u2fixed
bookworm, sid2.2.17-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
haproxysourcestretch(not affected)
haproxysourcebuster(not affected)
haproxysourcebullseye2.2.9-2+deb11u2DSA-4968-1
haproxysource(unstable)2.2.16-3

Notes

[buster] - haproxy <not-affected> (Vulnerable code not present)
[stretch] - haproxy <not-affected> (Vulnerable code not present)
https://www.mail-archive.com/haproxy@formilux.org/msg41114.html
https://git.haproxy.org/?p=haproxy.git;a=commit;h=3b69886f7dcc3cfb3d166309018e6cfec9ce2c95

Search for package or bug name: Reporting problems