CVE-2021-41079

NameCVE-2021-41079
DescriptionApache Tomcat 8.5.0 to 8.5.63, 9.0.0-M1 to 9.0.43 and 10.0.0-M1 to 10.0.2 did not properly validate incoming TLS packets. When Tomcat was configured to use NIO+OpenSSL or NIO2+OpenSSL for TLS, a specially crafted packet could be used to trigger an infinite loop resulting in a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2764-1, DSA-4986-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat8 (PTS)stretch8.5.54-0+deb9u1vulnerable
stretch (security)8.5.54-0+deb9u8fixed
tomcat9 (PTS)buster9.0.31-1~deb10u5vulnerable
buster (security)9.0.31-1~deb10u6fixed
bullseye9.0.43-2~deb11u1vulnerable
bullseye (security)9.0.43-2~deb11u3fixed
bookworm, sid9.0.55-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat8sourcestretch8.5.54-0+deb9u8DLA-2764-1
tomcat8source(unstable)(unfixed)
tomcat9sourcebuster9.0.31-1~deb10u6DSA-4986-1
tomcat9sourcebullseye9.0.43-2~deb11u2DSA-4986-1
tomcat9source(unstable)9.0.53-1

Notes

https://lists.apache.org/thread.html/rccdef0349fdf4fb73a4e4403095446d7fe6264e0a58e2df5c6799434%40%3Cannounce.tomcat.apache.org%3E
https://github.com/apache/tomcat/commit/d4b340fa8feaf55831f9a59350578f7b6ca048b8 (9.0.44)
https://github.com/apache/tomcat/commit/b90d4fc1ff44f30e4b3aba622ba6677e3f003822 (8.5.64)

Search for package or bug name: Reporting problems