CVE-2021-41499

NameCVE-2021-41499
DescriptionBuffer Overflow Vulnerability exists in ajaxsoundstudio.com n Pyo < 1.03 in the Server_debug function, which allows remote attackers to conduct DoS attacks by deliberately passing on an overlong audio file name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pyo (PTS)stretch0.8.2-1vulnerable
buster0.9.1-1vulnerable
bullseye1.0.3-0.1vulnerable
bookworm, sid1.0.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pyosource(unstable)1.0.4-1

Notes

[stretch] - python-pyo <no-dsa> (Minor issue)
https://github.com/belangeo/pyo/issues/222
https://github.com/belangeo/pyo/commit/e7e6d2880469b523e4c41f0da2087a6a3eec4a45 (1.0.4)

Search for package or bug name: Reporting problems