CVE-2021-41500

NameCVE-2021-41500
DescriptionIncomplete string comparison vulnerability exits in cvxopt.org cvxop <= 1.2.6 in APIs (cvxopt.cholmod.diag, cvxopt.cholmod.getfactor, cvxopt.cholmod.solve, cvxopt.cholmod.spsolve), which allows attackers to conduct Denial of Service attacks by construct fake Capsule objects.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cvxopt (PTS)stretch1.1.4-1.5+deb9u1vulnerable
buster1.1.9+dfsg-3vulnerable
bullseye1.2.5+dfsg-3vulnerable
bookworm, sid1.2.7+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cvxoptsource(unstable)1.2.7+dfsg-1

Notes

[bullseye] - cvxopt <no-dsa> (Minor issue)
[buster] - cvxopt <no-dsa> (Minor issue)
[stretch] - cvxopt <no-dsa> (Minor issue)
https://github.com/cvxopt/cvxopt/issues/193

Search for package or bug name: Reporting problems