CVE-2021-41736

NameCVE-2021-41736
DescriptionFaust v2.35.0 was discovered to contain a heap-buffer overflow in the function realPropagate() at propagate.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faust (PTS)stretch0.9.95~repack1-2vulnerable
buster2.14.4~repack2-1vulnerable
bullseye2.30.5~ds0-2vulnerable
bookworm, sid2.40.0~ds0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faustsource(unstable)(unfixed)

Notes

[bullseye] - faust <no-dsa> (Minor issue)
[buster] - faust <no-dsa> (Minor issue)
[stretch] - faust <postponed> (Minor issue, no patch/acknowledgment yet)
https://github.com/grame-cncm/faust/issues/653

Search for package or bug name: Reporting problems