|Description||ModSecurity 3.x through 3.0.5 mishandles excessively nested JSON objects. Crafted JSON objects with nesting tens-of-thousands deep could result in the web server being unable to service legitimate requests. Even a moderately large (e.g., 300KB) HTTP request can occupy one of the limited NGINX worker processes for minutes and consume almost all of the available CPU on the machine. Modsecurity 2 is similarly vulnerable: the affected versions include 2.8.0 through 2.9.4.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)|
Vulnerable and fixed packages
The table below lists information on source packages.
|modsecurity (PTS)||buster, buster (security)||3.0.3-1+deb10u2||vulnerable|
|bullseye (security), bullseye||2.9.3-3+deb11u1||fixed|
|bookworm, sid, trixie||2.9.7-1||fixed|
The information below is based on the following data on fixed versions.
[bullseye] - modsecurity <no-dsa> (Minor issue; does not have connector packages in Debian)
[buster] - modsecurity <no-dsa> (Minor issue; does not have connector packages in Debian)
Fixed by: https://github.com/SpiderLabs/ModSecurity/commit/41918335fa4c74fba46a986771a5a6cb457070c4 (v2.9.5)
Fixed by: https://github.com/SpiderLabs/ModSecurity/commit/ac79c1c29b7e6323e26cc984ad4f76ef62c731cd (v3.0.6)