CVE-2021-42762

NameCVE-2021-42762
DescriptionBubblewrapLauncher.cpp in WebKitGTK and WPE WebKit before 2.34.1 allows a limited sandbox bypass that allows a sandboxed process to trick host processes into thinking the sandboxed process is not confined by the sandbox, by abusing VFS syscalls that manipulate its filesystem namespace. The impact is limited to host services that create UNIX sockets that WebKit mounts inside its sandbox, and the sandboxed process remains otherwise confined. NOTE: this is similar to CVE-2021-41133.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4995-1, DSA-4996-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)stretch2.18.6-1~deb9u1vulnerable
buster2.32.4-1~deb10u1vulnerable
buster (security)2.34.1-1~deb10u1fixed
bullseye2.32.4-1~deb11u1vulnerable
bullseye (security)2.34.1-1~deb11u1fixed
bookworm, sid2.34.2-1fixed
wpewebkit (PTS)bullseye2.32.4-1~deb11u1vulnerable
bullseye (security)2.34.1-1~deb11u1fixed
bookworm, sid2.34.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.34.1-1~deb10u1DSA-4995-1
webkit2gtksourcebullseye2.34.1-1~deb11u1DSA-4995-1
webkit2gtksource(unstable)2.34.1-1
wpewebkitsourcebullseye2.34.1-1~deb11u1DSA-4996-1
wpewebkitsource(unstable)2.34.1-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
https://bugs.webkit.org/show_bug.cgi?id=231479
https://github.com/flatpak/flatpak/security/advisories/GHSA-67h7-w3jq-vh4q

Search for package or bug name: Reporting problems