CVE-2021-43618

NameCVE-2021-43618
DescriptionGNU Multiple Precision Arithmetic Library (GMP) through 6.2.1 has an mpz/inp_raw.c integer overflow and resultant buffer overflow via crafted input, leading to a segmentation fault on 32-bit platforms.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2837-1
NVD severitymedium
Debian Bugs994405

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gmp (PTS)stretch2:6.1.2+dfsg-1vulnerable
stretch (security)2:6.1.2+dfsg-1+deb9u1fixed
buster2:6.1.2+dfsg-4vulnerable
bullseye2:6.2.1+dfsg-1vulnerable
bookworm, sid2:6.2.1+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gmpsourcestretch2:6.1.2+dfsg-1+deb9u1DLA-2837-1
gmpsource(unstable)2:6.2.1+dfsg-3994405

Notes

[bullseye] - gmp <no-dsa> (Minor issue)
[buster] - gmp <no-dsa> (Minor issue)
https://gmplib.org/list-archives/gmp-bugs/2021-September/005077.html
https://gmplib.org/repo/gmp-6.2/rev/561a9c25298e

Search for package or bug name: Reporting problems