CVE-2021-43818

NameCVE-2021-43818
Descriptionlxml is a library for processing XML and HTML in the Python language. Prior to version 4.6.5, the HTML Cleaner in lxml.html lets certain crafted script content pass through, as well as script content in SVG files embedded using data URIs. Users that employ the HTML cleaner in a security relevant context should upgrade to lxml 4.6.5 to receive a patch. There are no known workarounds available.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2871-1, DSA-5043-1
Debian Bugs1001885

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lxml (PTS)buster, buster (security)4.3.2-1+deb10u4fixed
bullseye (security), bullseye4.6.3+dfsg-0.1+deb11u1fixed
bookworm, sid4.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lxmlsourcestretch3.7.1-1+deb9u5DLA-2871-1
lxmlsourcebuster4.3.2-1+deb10u4DSA-5043-1
lxmlsourcebullseye4.6.3+dfsg-0.1+deb11u1DSA-5043-1
lxmlsource(unstable)4.7.1-11001885

Notes

https://github.com/lxml/lxml/security/advisories/GHSA-55x5-fj6c-h6m8
https://github.com/lxml/lxml/commit/12fa9669007180a7bb87d990c375cf91ca5b664a (lxml-4.6.5)
https://github.com/lxml/lxml/commit/f2330237440df7e8f39c3ad1b1aa8852be3b27c0 (lxml-4.6.5)

Search for package or bug name: Reporting problems