CVE-2021-44224

NameCVE-2021-44224
DescriptionA crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2907-1, DSA-5035-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)stretch2.4.25-3+deb9u9vulnerable
stretch (security)2.4.25-3+deb9u13fixed
buster, buster (security)2.4.38-3+deb10u7fixed
bullseye2.4.53-1~deb11u1fixed
bullseye (security)2.4.52-1~deb11u2fixed
bookworm, sid2.4.54-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2sourcestretch2.4.25-3+deb9u12DLA-2907-1
apache2sourcebuster2.4.38-3+deb10u7DSA-5035-1
apache2sourcebullseye2.4.52-1~deb11u2DSA-5035-1
apache2source(unstable)2.4.52-1

Notes

https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2021-44224
Fixed by: https://svn.apache.org/r1895955
Fixed by: https://svn.apache.org/r1896044

Search for package or bug name: Reporting problems