CVE-2021-44273

NameCVE-2021-44273
Descriptione2guardian v5.4.x <= v5.4.3r is affected by missing SSL certificate validation in the SSL MITM engine. In standalone mode (i.e., acting as a proxy or a transparent proxy), with SSL MITM enabled, e2guardian, if built with OpenSSL v1.1.x, did not validate hostnames in certificates of the web servers that it connected to, and thus was itself vulnerable to MITM attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1003125

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
e2guardian (PTS)stretch3.4.0.3-2vulnerable
buster5.3.1-1vulnerable
bullseye5.3.4-1+deb11u1fixed
bookworm, sid5.3.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
e2guardiansourcebullseye5.3.4-1+deb11u1
e2guardiansource(unstable)5.3.5-31003125

Notes

[buster] - e2guardian <no-dsa> (Minor issue)
[stretch] - e2guardian <ignored> (SSL MITM engine not enabled in stretch)
https://www.openwall.com/lists/oss-security/2021/12/23/2
https://github.com/e2guardian/e2guardian/issues/707
Fixed by: https://github.com/e2guardian/e2guardian/commit/eae46a7e2a57103aadca903c4a24cca94dc502a2

Search for package or bug name: Reporting problems