CVE-2021-44730

NameCVE-2021-44730
Descriptionsnapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5080-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
snapd (PTS)stretch2.21-2vulnerable
stretch (security)2.21-2+deb9u1vulnerable
buster2.37.4-1vulnerable
buster (security)2.37.4-1+deb10u1fixed
bullseye, bullseye (security)2.49-1+deb11u1fixed
bookworm, sid2.54.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
snapdsourcebuster2.37.4-1+deb10u1DSA-5080-1
snapdsourcebullseye2.49-1+deb11u1DSA-5080-1
snapdsource(unstable)2.54.3-1

Notes

https://www.openwall.com/lists/oss-security/2022/02/17/2

Search for package or bug name: Reporting problems