CVE-2021-44854

NameCVE-2021-44854
DescriptionREST API incorrectly publicly caches autocomplete search results from private wikis
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5246-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)buster1:1.31.16-1+deb10u2fixed
buster (security)1:1.31.16-1+deb10u4fixed
bullseye1:1.35.4-1+deb11u2vulnerable
bullseye (security)1:1.35.8-1~deb11u1fixed
bookworm1:1.35.8-1.1fixed
sid1:1.39.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcestretch(not affected)
mediawikisourcebuster(not affected)
mediawikisourcebullseye1:1.35.8-1~deb11u1DSA-5246-1
mediawikisource(unstable)1:1.35.5-1

Notes

[buster] - mediawiki <not-affected> (Vulnerable code not present)
[stretch] - mediawiki <not-affected> (Vulnerable code not present)
https://phabricator.wikimedia.org/T292763
https://lists.wikimedia.org/hyperkitty/list/wikitech-l@lists.wikimedia.org/thread/QEN3EK4JXAVJMJ5GF3GYOAKNJPEKFQYA/

Search for package or bug name: Reporting problems