CVE-2021-44917

NameCVE-2021-44917
DescriptionA Divide by Zero vulnerability exists in gnuplot 5.4 in the boundary3d function in graph3d.c, which could cause a Arithmetic exception and application crash.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs1002539

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnuplot (PTS)stretch5.0.5+dfsg1-6+deb9u1vulnerable
buster5.2.6+dfsg1-1+deb10u1vulnerable
bullseye5.4.1+dfsg1-1vulnerable
bookworm, sid5.4.2+dfsg2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnuplotsource(unstable)5.4.2+dfsg2-2unimportant1002539

Notes

https://sourceforge.net/p/gnuplot/bugs/2474/
https://sourceforge.net/p/gnuplot/gnuplot-main/ci/8938dfc937348f1d4e7b3d6ef6d44209b1d89473/ (master)
https://sourceforge.net/p/gnuplot/gnuplot-main/ci/acab14de21e323254507fca85f964e471258ac82/ (master)
https://sourceforge.net/p/gnuplot/gnuplot-main/ci/4cc2a4c83bc95470caa525cda52fba683e95bbb9/ (master)
https://sourceforge.net/p/gnuplot/gnuplot-main/ci/7285b0c578a067d8d9fe0566ccefaee131f62087/ (branch-5-4-stable)
https://sourceforge.net/p/gnuplot/gnuplot-main/ci/bac7cf51333242999ecb66883fd6076168ec3441/ (branch-5-4-stable)
Crash in CLI tool, negligible security impact

Search for package or bug name: Reporting problems