CVE-2021-45417

NameCVE-2021-45417
DescriptionAIDE before 0.17.4 allows local users to obtain root privileges via crafted file metadata (such as XFS extended attributes or tmpfs ACLs), because of a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2894-1, DSA-5051-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
aide (PTS)buster, buster (security)0.16.1-1+deb10u1fixed
bullseye (security), bullseye0.17.3-4+deb11u1fixed
bookworm, sid0.17.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
aidesourcestretch0.16-1+deb9u1DLA-2894-1
aidesourcebuster0.16.1-1+deb10u1DSA-5051-1
aidesourcebullseye0.17.3-4+deb11u1DSA-5051-1
aidesource(unstable)0.17.4-1

Notes

https://github.com/aide/aide/commit/175d1f2626f4500b4fc5ecb7167bba9956b174bc (v0.17.4)
https://www.openwall.com/lists/oss-security/2022/01/20/3

Search for package or bug name: Reporting problems