CVE-2021-45940

NameCVE-2021-45940
Descriptionlibbpf 0.6.0 and 0.6.1 has a heap-based buffer overflow (4 bytes) in __bpf_object__open (called from bpf_object__open_mem and bpf-object-fuzzer.c).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libbpf (PTS)bullseye0.3-2vulnerable
bookworm, sid1.0.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libbpfsource(unstable)0.7.0-2

Notes

[bullseye] - libbpf <postponed> (No actionable information, revisit when/if more details available)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=40868
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/libbpf/OSV-2021-1562.yaml
Fixed in 0.7.0 upstream per identified range of commits
It's unclear if 0.3 is affected, the introducing commit presented by oss-fuzz is misleading
since that refers to the first version when oss-fuzz started to test libbpf. If anyone confirms
via bisecting that 0.3.0 is affected, this can be revisited

Search for package or bug name: Reporting problems