CVE-2021-45944

NameCVE-2021-45944
DescriptionGhostscript GhostPDL 9.50 through 9.53.3 has a use-after-free in sampled_data_sample (called from sampled_data_continue and interp).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2879-1, DSA-5038-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)stretch9.26a~dfsg-0+deb9u6vulnerable
stretch (security)9.26a~dfsg-0+deb9u9fixed
buster, buster (security)9.27~dfsg-2+deb10u5fixed
bullseye (security), bullseye9.53.3~dfsg-7+deb11u2fixed
bookworm, sid9.56.1~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsourcestretch9.26a~dfsg-0+deb9u8DLA-2879-1
ghostscriptsourcebuster9.27~dfsg-2+deb10u5DSA-5038-1
ghostscriptsourcebullseye9.53.3~dfsg-7+deb11u2DSA-5038-1
ghostscriptsource(unstable)9.54.0~dfsg-5

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=29903
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/ghostscript/OSV-2021-237.yaml
https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=7861fcad13c497728189feafb41cd57b5b50ea25

Search for package or bug name: Reporting problems