CVE-2021-46657

NameCVE-2021-46657
Descriptionget_sort_by_table in MariaDB before 10.6.2 allows an application crash via certain subquery uses of ORDER BY.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mariadb-10.3 (PTS)buster1:10.3.34-0+deb10u1fixed
buster (security)1:10.3.25-0+deb10u1vulnerable
mariadb-10.5 (PTS)bullseye1:10.5.15-0+deb11u1fixed
mariadb-10.6 (PTS)bookworm, sid1:10.6.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mariadb-10.3sourcebuster1:10.3.31-0+deb10u1
mariadb-10.3source(unstable)(unfixed)
mariadb-10.5source(unstable)1:10.5.11-1
mariadb-10.6source(unstable)(not affected)

Notes

- mariadb-10.6 <not-affected> (Fixed before initial upload to Debian)
[bullseye] - mariadb-10.5 <no-dsa> (Minor issue, will be fixed in next point release)
https://jira.mariadb.org/browse/MDEV-25629
Fixed in MariaDB: 10.2.39, 10.3.30, 10.4.20, 10.5.11, 10.6.2

Search for package or bug name: Reporting problems