CVE-2021-46823

NameCVE-2021-46823
Descriptionpython-ldap before 3.4.0 is vulnerable to a denial of service when ldap.schema is used for untrusted schema definitions, because of a regular expression denial of service (ReDoS) flaw in the LDAP schema parser. By sending crafted regex input, a remote authenticated attacker could exploit this vulnerability to cause a denial of service condition.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-ldap (PTS)buster3.1.0-2vulnerable
bookworm, bullseye3.2.0-4vulnerable
sid3.4.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-ldapsource(unstable)3.4.0-1

Notes

[bullseye] - python-ldap <no-dsa> (Minor issue)
[buster] - python-ldap <no-dsa> (Minor issue)
[stretch] - python-ldap <no-dsa> (Minor issue)
https://github.com/python-ldap/python-ldap/security/advisories/GHSA-r8wq-qrxc-hmcm

Search for package or bug name: Reporting problems