CVE-2022-0430

NameCVE-2022-0430
DescriptionExposure of Sensitive Information to an Unauthorized Actor in GitHub repository httpie/httpie prior to 3.1.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
httpie (PTS)stretch0.9.8-1vulnerable
buster0.9.8-2vulnerable
bullseye2.2.0-2vulnerable
bookworm, sid2.6.0-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
httpiesource(unstable)(unfixed)

Notes

[bullseye] - httpie <no-dsa> (Minor issue)
[buster] - httpie <no-dsa> (Minor issue)
[stretch] - httpie <no-dsa> (Minor issue)
https://huntr.dev/bounties/dafb2e4f-c6b6-4768-8ef5-b396cd6a801f
Fixed by: https://github.com/httpie/httpie/commit/65ab7d5caaaf2f95e61f9dd65441801c2ddee38b (3.1.0)

Search for package or bug name: Reporting problems