CVE-2022-0544

NameCVE-2022-0544
DescriptionAn integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3060-1, DSA-5176-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
blender (PTS)buster, buster (security)2.79.b+dfsg0-7+deb10u1fixed
bullseye (security), bullseye2.83.5+dfsg-5+deb11u1fixed
sid3.3.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
blendersourcestretch2.79.b+dfsg0-1~deb9u2DLA-3060-1
blendersourcebuster2.79.b+dfsg0-7+deb10u1DSA-5176-1
blendersourcebullseye2.83.5+dfsg-5+deb11u1DSA-5176-1
blendersource(unstable)3.1.2+dfsg-1

Notes

Issue: https://developer.blender.org/T94661
https://developer.blender.org/rBd9dd8c287f57716a827483973c31bbb2face2816 (v3.1.0)
https://developer.blender.org/rBbbad834f1c2a1f7030ed9741c486b23241e8885e (v2.93.8)
https://developer.blender.org/rB0ac83d05d7cccec436bb939e0aa768f6a3d77d72 (v2.83.19)

Search for package or bug name: Reporting problems