CVE-2022-0545

NameCVE-2022-0545
DescriptionAn integer overflow in the processing of loaded 2D images leads to a write-what-where vulnerability and an out-of-bounds read vulnerability, allowing an attacker to leak sensitive information or achieve code execution in the context of the Blender process when a specially crafted image file is loaded. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
blender (PTS)stretch (security), stretch2.79.b+dfsg0-1~deb9u1vulnerable
buster2.79.b+dfsg0-7vulnerable
bullseye2.83.5+dfsg-5vulnerable
sid3.1.2+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
blendersource(unstable)(unfixed)

Notes

Issue: https://developer.blender.org/T94629
Patch: https://developer.blender.org/D13744

Search for package or bug name: Reporting problems