CVE-2022-0669

NameCVE-2022-0669
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5130-1
Debian Bugs1010641

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dpdk (PTS)stretch (security), stretch16.11.11-1+deb9u2fixed
buster18.11.11-1~deb10u1fixed
buster (security)18.11.6-1~deb10u2fixed
bullseye20.11.4-2~deb11u1vulnerable
bullseye (security)20.11.5-1~deb11u1fixed
bookworm, sid20.11.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dpdksourcestretch(not affected)
dpdksourcebuster(not affected)
dpdksourcebullseye20.11.5-1~deb11u1DSA-5130-1
dpdksource(unstable)20.11.5-11010641

Notes

[buster] - dpdk <not-affected> (Vulnerable code introduced later)
[stretch] - dpdk <not-affected> (Vulnerable code introduced later)
https://bugs.dpdk.org/show_bug.cgi?id=922
Introduced by: https://github.com/DPDK/dpdk/commit/d87f1a1cb7b666550bb53e39c1d85d9f7b861e6f (v19.11-rc1)
Fixed by: https://github.com/DPDK/dpdk/commit/af74f7db384ed149fe42b21dbd7975f8a54ef227 (v22.03-rc4)

Search for package or bug name: Reporting problems