CVE-2022-0759

NameCVE-2022-0759
DescriptionA flaw was found in all versions of kubeclient up to (but not including) v4.9.3, the Ruby client for Kubernetes REST API, in the way it parsed kubeconfig files. When the kubeconfig file does not configure custom CA to verify certs, kubeclient ends up accepting any certificate (it wrongly returns VERIFY_NONE). Ruby applications that leverage kubeclient to parse kubeconfig files are susceptible to Man-in-the-middle attacks (MITM).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-kubeclient (PTS)buster4.2.0-2vulnerable
bullseye4.9.1-2vulnerable
bookworm, sid4.9.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-kubeclientsource(unstable)(unfixed)

Notes

[bullseye] - ruby-kubeclient <no-dsa> (Minor issue)
[buster] - ruby-kubeclient <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=2058404
https://github.com/ManageIQ/kubeclient/issues/554
https://github.com/ManageIQ/kubeclient/pull/556
https://github.com/ManageIQ/kubeclient/issues/555
https://github.com/ManageIQ/kubeclient/pull/556

Search for package or bug name: Reporting problems