CVE-2022-1475

NameCVE-2022-1475
DescriptionAn integer overflow vulnerability was found in FFmpeg versions before 4.4.2 and before 5.0.1 in g729_parse() in llibavcodec/g729_parser.c when processing a specially crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5124-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)buster7:4.1.9-0+deb10u1fixed
buster (security)7:4.1.10-0+deb10u1fixed
bullseye (security), bullseye7:4.3.5-0+deb11u1fixed
bookworm, sid7:5.1.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourcestretch(not affected)
ffmpegsourcebuster(not affected)
ffmpegsourcebullseye7:4.3.4-0+deb11u1DSA-5124-1
ffmpegsource(unstable)7:4.4.2-1

Notes

[buster] - ffmpeg <not-affected> (Vulnerable code not present)
[stretch] - ffmpeg <not-affected> (Vulnerable code not present)
https://trac.ffmpeg.org/ticket/9651
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=757da974b21833529cc41bdcc9684c29660cdfa8
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=e9e2ddbc6c78cc18b76093617f82c920e58a8d1f (n4.4.2)
https://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=fa2e4afe8d0a23fac37392ef6506cfc9841f8d3d (n4.3.4)

Search for package or bug name: Reporting problems