CVE-2022-1552

NameCVE-2022-1552
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5135-1, DSA-5136-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-11 (PTS)buster11.14-0+deb10u1vulnerable
buster (security)11.16-0+deb10u1fixed
postgresql-13 (PTS)bullseye13.5-0+deb11u1vulnerable
bullseye (security)13.7-0+deb11u1fixed
postgresql-14 (PTS)bookworm, sid14.3-1fixed
postgresql-9.6 (PTS)stretch9.6.17-0+deb9u1vulnerable
stretch (security)9.6.24-0+deb9u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-11sourcebuster11.16-0+deb10u1DSA-5135-1
postgresql-11source(unstable)(unfixed)
postgresql-13sourcebullseye13.7-0+deb11u1DSA-5136-1
postgresql-13source(unstable)(unfixed)
postgresql-14source(unstable)14.3-1
postgresql-9.6source(unstable)(unfixed)

Notes

https://www.postgresql.org/about/news/postgresql-143-137-1211-1116-and-1021-released-2449/
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=ab49ce7c3414ac19e4afb386d7843ce2d2fb8bda (REL_14_3)
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=677a494789062ca88e0142a17bedd5415f6ab0aa (REL_14_3)

Search for package or bug name: Reporting problems