CVE-2022-1587

NameCVE-2022-1587
DescriptionAn out-of-bounds read vulnerability was discovered in the PCRE2 library in the get_recurse_data_length() function of the pcre2_jit_compile.c file. This issue affects recursions in JIT-compiled regular expressions caused by duplicate data transfers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1011954

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcre2 (PTS)buster10.32-5vulnerable
bullseye10.36-2+deb11u1fixed
bookworm, sid10.40-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcre2sourcebullseye10.36-2+deb11u1
pcre2source(unstable)10.40-11011954

Notes

[buster] - pcre2 <no-dsa> (Minor issue)
[stretch] - pcre2 <no-dsa> (Minor issue)
https://github.com/PCRE2Project/pcre2/commit/03654e751e7f0700693526b67dfcadda6b42c9d0 (pcre2-10.40)

Search for package or bug name: Reporting problems