CVE-2022-2047

NameCVE-2022-2047
DescriptionIn Eclipse Jetty versions 9.4.0 thru 9.4.46, and 10.0.0 thru 10.0.9, and 11.0.0 thru 11.0.9 versions, the parsing of the authority segment of an http scheme URI, the Jetty HttpURI class improperly detects an invalid input as a hostname. This can lead to failures in a Proxy scenario.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3079-1, DSA-5198-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)buster9.4.16-0+deb10u1vulnerable
buster (security)9.4.16-0+deb10u2fixed
bullseye (security), bullseye9.4.39-3+deb11u1fixed
bookworm, sid9.4.50-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jetty9sourcebuster9.4.16-0+deb10u2DLA-3079-1
jetty9sourcebullseye9.4.39-3+deb11u1DSA-5198-1
jetty9source(unstable)9.4.48-1

Notes

https://github.com/eclipse/jetty.project/security/advisories/GHSA-cj7v-27pg-wf7q
https://github.com/eclipse/jetty.project/pull/8146

Search for package or bug name: Reporting problems