CVE-2022-2048

NameCVE-2022-2048
DescriptionIn Eclipse Jetty HTTP/2 server implementation, when encountering an invalid HTTP/2 request, the error handling has a bug that can wind up not properly cleaning up the active connections and associated resources. This can lead to a Denial of Service scenario where there are no enough resources left to process good requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3079-1, DSA-5198-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)buster9.4.16-0+deb10u1vulnerable
buster (security)9.4.16-0+deb10u2fixed
bullseye (security), bullseye9.4.39-3+deb11u1fixed
bookworm, sid9.4.50-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jetty9sourcebuster9.4.16-0+deb10u2DLA-3079-1
jetty9sourcebullseye9.4.39-3+deb11u1DSA-5198-1
jetty9source(unstable)9.4.48-1

Notes

https://github.com/eclipse/jetty.project/security/advisories/GHSA-wgmr-mf83-7x4j
https://github.com/eclipse/jetty.project/issues/7935

Search for package or bug name: Reporting problems