CVE-2022-2122

NameCVE-2022-2122
DescriptionDOS / potential heap overwrite in qtdemux using zlib decompression. Integer overflow in qtdemux element in qtdemux_inflate function which causes a segfault, or could cause a heap overwrite, depending on libc and OS. Depending on the libc used, and the underlying OS capabilities, it could be just a segfault or a heap overwrite.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3069-1, DSA-5204-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-good1.0 (PTS)buster1.14.4-1+deb10u1vulnerable
buster (security)1.14.4-1+deb10u2fixed
bullseye (security), bullseye1.18.4-2+deb11u1fixed
bookworm, sid1.20.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-good1.0sourcebuster1.14.4-1+deb10u2DLA-3069-1
gst-plugins-good1.0sourcebullseye1.18.4-2+deb11u1DSA-5204-1
gst-plugins-good1.0source(unstable)1.20.3-1

Notes

https://gstreamer.freedesktop.org/security/sa-2022-0003.html
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1225
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/14d306da6da51a762c4dc701d161bb52ab66d774
https://gitlab.freedesktop.org/gstreamer/gstreamer/-/commit/92b5eb1da30fda054daf2f3d30bb4b806910b234 (1.20.3)

Search for package or bug name: Reporting problems