CVE-2022-21227

NameCVE-2022-21227
DescriptionThe package sqlite3 before 5.0.3 are vulnerable to Denial of Service ( ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-sqlite3 (PTS)buster4.0.6+ds1-2vulnerable
bullseye5.0.0+ds1-1vulnerable
bookworm, sid5.0.8+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-sqlite3sourcestretch(unfixed)end-of-life
node-sqlite3source(unstable)5.0.6+ds1-1

Notes

[bullseye] - node-sqlite3 <no-dsa> (Minor issue)
[buster] - node-sqlite3 <no-dsa> (minor issue)
[stretch] - node-sqlite3 <end-of-life> (Nodejs in stretch not covered by security support)
https://github.com/advisories/GHSA-9qrh-qjmc-5w2p
Fixed by: https://github.com/TryGhost/node-sqlite3/commit/593c9d498be2510d286349134537e3bf89401c4a (v5.0.3)
https://security.snyk.io/vuln/SNYK-JS-SQLITE3-2388645

Search for package or bug name: Reporting problems