CVE-2022-22707

NameCVE-2022-22707
DescriptionIn lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5040-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lighttpd (PTS)stretch1.4.45-1fixed
stretch (security)1.4.45-1+deb9u1fixed
buster, buster (security)1.4.53-4+deb10u2fixed
bullseye (security), bullseye1.4.59-1+deb11u1fixed
bookworm, sid1.4.65-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lighttpdsourcestretch(not affected)
lighttpdsourcebuster1.4.53-4+deb10u2DSA-5040-1
lighttpdsourcebullseye1.4.59-1+deb11u1DSA-5040-1
lighttpdsource(unstable)1.4.64-1

Notes

[stretch] - lighttpd <not-affected> (Vulnerable code not present; the issue was introduced in later versions)
https://redmine.lighttpd.net/issues/3134
https://github.com/lighttpd/lighttpd1.4/commit/8c62a890e23f5853b1a562b03fe3e1bccc6e7664

Search for package or bug name: Reporting problems