CVE-2022-23318

NameCVE-2022-23318
DescriptionA heap-buffer-overflow in pcf2bdf, versions >= 1.05 allows an attacker to trigger unsafe memory access via a specially crafted PCF font file. This out-of-bound read may lead to an application crash, information disclosure via program memory or other context-dependent impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pcf2bdf (PTS)buster1.05-1vulnerable
bullseye1.06-1vulnerable
bookworm, sid1.07-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pcf2bdfsource(unstable)1.07-1unimportant

Notes

https://github.com/ganaware/pcf2bdf/issues/4
https://github.com/advisories/GHSA-mhwp-x94h-mg49
Fixed by: https://github.com/ganaware/pcf2bdf/commit/aaf16808e4bb8d96eeab5f684df6550912a9e694 (1.07)
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems