CVE-2022-23457

NameCVE-2022-23457
DescriptionESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, the default implementation of `Validator.getValidDirectoryPath(String, String, File, boolean)` may incorrectly treat the tested input string as a child of the specified parent directory. This potentially could allow control-flow bypass checks to be defeated if an attack can specify the entire string representing the 'input' path. This vulnerability is patched in release 2.3.0.0 of ESAPI. As a workaround, it is possible to write one's own implementation of the Validator interface. However, maintainers do not recommend this.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1010339

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libowasp-esapi-java (PTS)buster2.1.0-3vulnerable
bullseye2.1.0-3.1vulnerable
bookworm, sid2.4.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libowasp-esapi-javasource(unstable)2.4.0.0-11010339

Notes

[bullseye] - libowasp-esapi-java <no-dsa> (Minor issue)
[buster] - libowasp-esapi-java <no-dsa> (Minor issue)
[stretch] - libowasp-esapi-java <no-dsa> (Minor issue)
https://securitylab.github.com/advisories/GHSL-2022-008_The_OWASP_Enterprise_Security_API/
https://github.com/ESAPI/esapi-java-legacy/security/advisories/GHSA-8m5h-hrqm-pxm2
https://github.com/ESAPI/esapi-java-legacy/blob/develop/documentation/esapi4java-core-2.3.0.0-release-notes.txt

Search for package or bug name: Reporting problems