DescriptionThe package cookiecutter before 2.1.1 are vulnerable to Command Injection via hg argument injection. When calling the cookiecutter function from Python code with the checkout parameter, it is passed to the hg checkout command in a way that additional flags can be set. The additional flags can be used to perform a command injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1013279

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cookiecutter (PTS)bookworm1.7.3-3vulnerable
sid, trixie2.6.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bookworm] - cookiecutter <no-dsa> (Minor issue)
[bullseye] - cookiecutter <no-dsa> (Minor issue)
[buster] - cookiecutter <no-dsa> (Minor issue)
[stretch] - cookiecutter <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems