CVE-2022-24065

NameCVE-2022-24065
DescriptionThe package cookiecutter before 2.1.1 are vulnerable to Command Injection via hg argument injection. When calling the cookiecutter function from Python code with the checkout parameter, it is passed to the hg checkout command in a way that additional flags can be set. The additional flags can be used to perform a command injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1013279

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cookiecutter (PTS)buster1.6.0-3vulnerable
bookworm, sid1.7.3-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cookiecuttersource(unstable)(unfixed)1013279

Notes

[buster] - cookiecutter <no-dsa> (Minor issue)
[stretch] - cookiecutter <no-dsa> (Minor issue)
https://security.snyk.io/vuln/SNYK-PYTHON-COOKIECUTTER-2414281
https://github.com/cookiecutter/cookiecutter/releases/tag/2.1.1
https://github.com/cookiecutter/cookiecutter/commit/fdffddb31fd2b46344dfa317531ff155e7999f77

Search for package or bug name: Reporting problems