CVE-2022-24070

NameCVE-2022-24070
DescriptionSubversion's mod_dav_svn is vulnerable to memory corruption. While looking up path-based authorization rules, mod_dav_svn servers may attempt to use memory which has already been freed. Affected Subversion mod_dav_svn servers 1.10.0 through 1.14.1 (inclusive). Servers that do not use mod_dav_svn are not affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-5119-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)stretch1.9.5-1+deb9u5fixed
stretch (security)1.9.5-1+deb9u6fixed
buster1.10.4-1+deb10u2vulnerable
buster (security)1.10.4-1+deb10u3fixed
bullseye1.14.1-3vulnerable
bullseye (security)1.14.1-3+deb11u1fixed
bookworm, sid1.14.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsourcestretch(not affected)
subversionsourcebuster1.10.4-1+deb10u3DSA-5119-1
subversionsourcebullseye1.14.1-3+deb11u1DSA-5119-1
subversionsource(unstable)1.14.2-1

Notes

[stretch] - subversion <not-affected> (Vulnerable codepaths added in 1.10.0-alpha1)
https://subversion.apache.org/security/CVE-2022-24070-advisory.txt

Search for package or bug name: Reporting problems