CVE-2022-24614

NameCVE-2022-24614
DescriptionWhen reading a specially crafted JPEG file, metadata-extractor up to 2.16.0 can be made to allocate large amounts of memory that finally leads to an out-of-memory error even for very small inputs. This could be used to mount a denial of service attack against services that use metadata-extractor library.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmetadata-extractor-java (PTS)bookworm, sid, buster, bullseye2.11.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmetadata-extractor-javasource(unstable)(unfixed)unimportant

Notes

https://github.com/drewnoakes/metadata-extractor/issues/561
Fixed in 2.18.0 but per upstream there's no real security impact:
https://github.com/drewnoakes/metadata-extractor/issues/561#issuecomment-1086967784

Search for package or bug name: Reporting problems