CVE-2022-24713

NameCVE-2022-24713
Descriptionregex is an implementation of regular expressions for the Rust language. The regex crate features built-in mitigations to prevent denial of service attacks caused by untrusted regexes, or untrusted input matched by trusted regexes. Those (tunable) mitigations already provide sane defaults to prevent attacks. This guarantee is documented and it's considered part of the crate's API. Unfortunately a bug was discovered in the mitigations designed to prevent untrusted regexes to take an arbitrary amount of time during parsing, and it's possible to craft regexes that bypass such mitigations. This makes it possible to perform denial of service attacks by sending specially crafted regexes to services accepting user-controlled, untrusted regexes. All versions of the regex crate before or equal to 1.5.4 are affected by this issue. The fix is include starting from regex 1.5.5. All users accepting user-controlled regexes are recommended to upgrade immediately to the latest version of the regex crate. Unfortunately there is no fixed set of problematic regexes, as there are practically infinite regexes that could be crafted to exploit this vulnerability. Because of this, it us not recommend to deny known problematic regexes.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2971-1, DLA-2978-1, DSA-5113-1, DSA-5118-1
NVD severitymedium
Debian Bugs1007176

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid100.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1vulnerable
stretch (security)91.9.0esr-1~deb9u1fixed
buster78.14.0esr-1~deb10u1vulnerable
buster (security)91.9.0esr-1~deb10u1fixed
bullseye78.15.0esr-1~deb11u1vulnerable
bullseye (security)91.9.0esr-1~deb11u1fixed
bookworm, sid91.9.0esr-1fixed
rust-regex (PTS)buster1.1.0-1vulnerable
bullseye1.3.7-1vulnerable
bookworm, sid1.5.5-1fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1vulnerable
stretch (security)1:91.8.0-1~deb9u1fixed
buster1:78.14.0-1~deb10u1vulnerable
buster (security)1:91.8.0-1~deb10u1fixed
bullseye1:78.14.0-1~deb11u1vulnerable
bullseye (security)1:91.8.0-1~deb11u1fixed
bookworm1:91.8.1-1fixed
sid1:91.9.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)99.0-1
firefox-esrsourcestretch91.8.0esr-1~deb9u1DLA-2971-1
firefox-esrsourcebuster91.8.0esr-1~deb10u1DSA-5113-1
firefox-esrsourcebullseye91.8.0esr-1~deb11u1DSA-5113-1
firefox-esrsource(unstable)91.8.0esr-1
rust-regexsource(unstable)1.5.5-11007176
thunderbirdsourcestretch1:91.8.0-1~deb9u1DLA-2978-1
thunderbirdsourcebuster1:91.8.0-1~deb10u1DSA-5118-1
thunderbirdsourcebullseye1:91.8.0-1~deb11u1DSA-5118-1
thunderbirdsource(unstable)1:91.8.0-1

Notes

https://rustsec.org/advisories/RUSTSEC-2022-0013.html
https://github.com/rust-lang/regex/security/advisories/GHSA-m5pq-gvj9-9vr8
https://github.com/rust-lang/regex/commit/ae70b41d4f46641dbc45c7a4f87954aea356283e (1.5.5)
https://groups.google.com/g/rustlang-security-announcements/c/NcNNL1Jq7Yw
https://www.mozilla.org/en-US/security/advisories/mfsa2022-13/#CVE-2022-24713
https://www.mozilla.org/en-US/security/advisories/mfsa2022-14/#CVE-2022-24713
https://www.mozilla.org/en-US/security/advisories/mfsa2022-15/#CVE-2022-24713

Search for package or bug name: Reporting problems