CVE-2022-24737

NameCVE-2022-24737
DescriptionHTTPie is a command-line HTTP client. HTTPie has the practical concept of sessions, which help users to persistently store some of the state that belongs to the outgoing requests and incoming responses on the disk for further usage. Before 3.1.0, HTTPie didn‘t distinguish between cookies and hosts they belonged. This behavior resulted in the exposure of some cookies when there are redirects originating from the actual host to a third party website. Users are advised to upgrade. There are no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs1008011

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
httpie (PTS)stretch0.9.8-1vulnerable
buster0.9.8-2vulnerable
bullseye2.2.0-2vulnerable
bookworm, sid2.6.0-1.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
httpiesource(unstable)(unfixed)1008011

Notes

[bullseye] - httpie <no-dsa> (Minor issue)
[buster] - httpie <no-dsa> (Minor issue)
[stretch] - httpie <no-dsa> (Minor issue)
https://github.com/httpie/httpie/security/advisories/GHSA-9w4w-cpc8-h2fq
Fixed by: https://github.com/httpie/httpie/commit/65ab7d5caaaf2f95e61f9dd65441801c2ddee38b (3.1.0)

Search for package or bug name: Reporting problems