CVE-2022-24754

NameCVE-2022-24754
DescriptionPJSIP is a free and open source multimedia communication library written in C language. In versions prior to and including 2.12 PJSIP there is a stack-buffer overflow vulnerability which only impacts PJSIP users who accept hashed digest credentials (credentials with data_type `PJSIP_CRED_DATA_DIGEST`). This issue has been patched in the master branch of the PJSIP repository and will be included with the next release. Users unable to upgrade need to check that the hashed digest data length must be equal to `PJSIP_MD5STRLEN` before passing to PJSIP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2962-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)stretch1:13.14.1~dfsg-2+deb9u4vulnerable
stretch (security)1:13.14.1~dfsg-2+deb9u6vulnerable
buster1:16.2.1~dfsg-1+deb10u2vulnerable
bullseye1:16.16.1~dfsg-1vulnerable
bullseye (security)1:16.16.1~dfsg-1+deb11u1vulnerable
bookworm, sid1:18.12.0~dfsg+~cs6.12.40431413-1vulnerable
pjproject (PTS)stretch2.5.5~dfsg-6+deb9u1vulnerable
stretch (security)2.5.5~dfsg-6+deb9u4fixed
ring (PTS)stretch20161221.2.7bd7d91~dfsg1-1vulnerable
stretch (security)20161221.2.7bd7d91~dfsg1-1+deb9u1vulnerable
buster20190215.1.f152c98~ds1-1+deb10u1vulnerable
sid, bullseye20210112.2.b757bac~ds1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksource(unstable)(unfixed)
pjprojectsourcestretch2.5.5~dfsg-6+deb9u3DLA-2962-1
pjprojectsource(unstable)(unfixed)
ringsource(unstable)(unfixed)

Notes

https://github.com/pjsip/pjproject/security/advisories/GHSA-73f7-48m9-w662
https://github.com/pjsip/pjproject/commit/d27f79da11df7bc8bb56c2f291d71e54df8d2c47

Search for package or bug name: Reporting problems