CVE-2022-24763

NameCVE-2022-24763
DescriptionPJSIP is a free and open source multimedia communication library written in the C language. Versions 2.12 and prior contain a denial-of-service vulnerability that affects PJSIP users that consume PJSIP's XML parsing in their apps. Users are advised to update. There are no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3036-1
Debian Bugs1014976, 1014998

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2vulnerable
bullseye (security), bullseye1:16.16.1~dfsg-1+deb11u1vulnerable
bookworm, sid1:18.14.0~~rc1~dfsg+~cs6.12.40431414-1fixed
ring (PTS)buster20190215.1.f152c98~ds1-1+deb10u1vulnerable
sid, bullseye20210112.2.b757bac~ds1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcestretch(not affected)
asterisksource(unstable)1:18.14.0~~rc1~dfsg+~cs6.12.40431414-11014976
pjprojectsourcestretch2.5.5~dfsg-6+deb9u5DLA-3036-1
pjprojectsource(unstable)(unfixed)
ringsource(unstable)(unfixed)1014998

Notes

[stretch] - asterisk <not-affected> (Vulnerable code not present)
https://github.com/pjsip/pjproject/security/advisories/GHSA-5x45-qp78-g4p4
https://github.com/pjsip/pjproject/commit/856f87c2e97a27b256482dbe0d748b1194355a21

Search for package or bug name: Reporting problems