CVE-2022-24764

NameCVE-2022-24764
DescriptionPJSIP is a free and open source multimedia communication library written in C. Versions 2.12 and prior contain a stack buffer overflow vulnerability that affects PJSUA2 users or users that call the API `pjmedia_sdp_print(), pjmedia_sdp_media_print()`. Applications that do not use PJSUA2 and do not directly call `pjmedia_sdp_print()` or `pjmedia_sdp_media_print()` should not be affected. A patch is available on the `master` branch of the `pjsip/pjproject` GitHub repository. There are currently no known workarounds.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2962-1, DLA-3194-1, DSA-5285-1
Debian Bugs1014976, 1014998

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2vulnerable
buster (security)1:16.28.0~dfsg-0+deb10u1fixed
bullseye1:16.16.1~dfsg-1+deb11u1vulnerable
bullseye (security)1:16.28.0~dfsg-0+deb11u1fixed
bookworm, sid1:20.0.0~dfsg+~cs6.12.40431414-2fixed
ring (PTS)buster20190215.1.f152c98~ds1-1+deb10u1vulnerable
bullseye, sid20210112.2.b757bac~ds1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcestretch(not affected)
asterisksourcebuster1:16.28.0~dfsg-0+deb10u1DLA-3194-1
asterisksourcebullseye1:16.28.0~dfsg-0+deb11u1DSA-5285-1
asterisksource(unstable)1:18.14.0~~rc1~dfsg+~cs6.12.40431414-11014976
pjprojectsourcestretch2.5.5~dfsg-6+deb9u3DLA-2962-1
pjprojectsource(unstable)(unfixed)
ringsource(unstable)(unfixed)1014998

Notes

[stretch] - asterisk <not-affected> (Vulnerable code not present)
https://github.com/pjsip/pjproject/security/advisories/GHSA-f5qg-pqcg-765m
https://github.com/pjsip/pjproject/commit/560a1346f87aabe126509bb24930106dea292b00

Search for package or bug name: Reporting problems