CVE-2022-25255

NameCVE-2022-25255
DescriptionIn Qt 5.9.x through 5.15.x before 5.15.9 and 6.x before 6.2.4 on Linux and UNIX, QProcess could execute a binary from the current working directory when not found in the PATH.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt6-base (PTS)bookworm6.3.1+dfsg-9fixed
sid6.3.1+dfsg-10fixed
qtbase-opensource-src (PTS)buster5.11.3+dfsg1-1+deb10u5vulnerable
buster (security)5.11.3+dfsg1-1+deb10u3vulnerable
bullseye5.15.2+dfsg-9vulnerable
bookworm5.15.4+dfsg-5fixed
sid5.15.6+dfsg-2fixed
qtbase-opensource-src-gles (PTS)bullseye5.15.2+dfsg-4vulnerable
bookworm5.15.4+dfsg-2fixed
sid5.15.6+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt6-basesource(unstable)6.2.4+dfsg-4
qtbase-opensource-srcsourcestretch(not affected)
qtbase-opensource-srcsource(unstable)5.15.2+dfsg-15
qtbase-opensource-src-glessource(unstable)5.15.4+dfsg-2

Notes

[bullseye] - qtbase-opensource-src <no-dsa> (Minor issue)
[buster] - qtbase-opensource-src <ignored> (Breaks existing behaviour and upstream also skipped from 5.12 branch)
[stretch] - qtbase-opensource-src <not-affected> (Vulnerable code introduced later)
[bullseye] - qtbase-opensource-src-gles <no-dsa> (Minor issue)
[buster] - qtbase-opensource-src-gles <ignored> (Breaks existing behaviour and upstream also skipped from 5.12 branch)
https://codereview.qt-project.org/c/qt/qtbase/+/393113
https://codereview.qt-project.org/c/qt/qtbase/+/394914
https://codereview.qt-project.org/c/qt/qtbase/+/396020
https://github.com/qt/qtbase/commit/ab6915f0efb12cfe48d1f126f4a828212f853ce5 (v6.2.4)
https://download.qt.io/official_releases/qt/5.15/qprocess5-15.diff
https://download.qt.io/official_releases/qt/6.2/qprocess6-2.diff
https://www.qt.io/blog/security-advisory-qprocess

Search for package or bug name: Reporting problems